Pensacola Fishing Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
507 Posts
Discussion Starter #1
I have a 2012 yamahammer that the rpms dont come back to idle after running at any kind of speed or big throttle demand such recovering on the trailer. Otherwise it runs fantastic.
I've cleaned the throttle body multiple times. I've pulled the throttle body and inspected for cracks or bad seals.
When I spray carb cleaner in the TB while running I get a slight rpm drop which is normal. I sprayed around mating area and got a little rpm drop when I sprayed the onboard side of the mating surface.
This led me to believe I have air leaking into the TB. Tried snuggling the TB mounts but it didn't help. I'd like to torque them properly . does anyone know the specs on those bolts?
Anyone else have this problem?
 

·
Jaded Old Phart
Joined
·
5,995 Posts
Just taking a WAG but maybe one of the gaskets need to be changed?

1070680
 

·
Registered
Joined
·
507 Posts
Discussion Starter #3
Just taking a WAG but maybe one of the gaskets need to be changed?

View attachment 1070680
Thats the first thing I thought of. Both the gasket and o ring appear to be in perfect shape. I've had the TB off twice and inspected it with a magnifying glass and a strong light. Everything looked good. The o ring is compressed as the mount bolts are tight end. The intake has threaded inserts mounted in plastic. My fist impulse it to crank down the bolts but the aircraft mechanic in me days not to. I want to try the proper torque, if that doesn't help I will replace the o ring and gasket.
You don't know the correct torque. The are 12mm bolts. 9.6 ft lbs is my best guess.
 

·
Registered
Joined
·
4,243 Posts
If you have a leak, it would cause an elevated idle, uncontrolled air , and the IAC can’t do its job, so will a sensor issue, aka ( code) , this will cause a idle of about 1000 rpm, might want to have a computer put on it and check it out.
 

·
Registered
Joined
·
507 Posts
Discussion Starter #7
If you have a leak, it would cause an elevated idle, uncontrolled air , and the IAC can’t do its job, so will a sensor issue, aka ( code) , this will cause a idle of about 1000 rpm, might want to have a computer put on it and check it out.
thanks. I believe you are right.
 
1 - 7 of 7 Posts
Top