Pensacola Fishing Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5,602 Posts
Discussion Starter #1
The drive on my outback had occasionally "popped" and "clicked" especially while pushing it hard. All of a sudden today on the way in it did it on every stroke and the left fin would hit the hull pretty hard if I did a full stroke.

It almost sounds like the chain is slipping. Once I got home I made sure both pedals where in the same hole but when they were exactly parallel to each other and straight up and down should the fins be straight up and down and parallel as well? The left one wasnt. Any experts out there that could help me fix this?
 

·
Registered
Joined
·
198 Posts
I know nothing about the drive system but there is no doubt that you have a indexing problem. I am sure some disassembly will be required to get it back into sync. Something is either loose, broken, or loose. Is the yak still in warranty? Was it still in warranty when it started popping? The fix should not be too expensive if not in warranty. There is probably only one, maybe two parts that will need be replaced worse case. I am assuming that the unit is designed to be repairable. I would be interested in what you find. I have been considering an outback myself.:watching:
 

·
Registered
Joined
·
3,310 Posts
My did the exact same thing today how ironic. I did notice the tension nuts to the cables seemed loose so I tightened all of them on both sides. Im not sure if it fixed it yet or not
 

·
Registered
Joined
·
5,602 Posts
Discussion Starter #6
So I got to looking at it and it looks like a few of the teeth have broken/ground off. Im not sure if it was like that when I got them or not but at the price I paid I guess it couldnt be perfect I suppose.

Can any of the local Hobie dealers order parts or do I need to order my self online?
 

·
Registered
Joined
·
332 Posts
Sorry that happened. In February, mine did something similar. I took it into Key Sailing, and even though I had bought it 13 months earlier, they honored my 12 month warranty and fixed everything for free. Back to new now. Big props to those guys. On mine, a pulley had worked a little loose, which led to a wobbling cable, then a crack in the frame, followed by pedal slippage, etc. pretty bad! Good luck. It probably didn't help that I used to try to set speed records with the turbo fins.
 

·
Registered
Joined
·
761 Posts
Sorry that happened. In February, mine did something similar. I took it into Key Sailing, and even though I had bought it 13 months earlier, they honored my 12 month warranty and fixed everything for free. Back to new now. Big props to those guys. On mine, a pulley had worked a little loose, which led to a wobbling cable, then a crack in the frame, followed by pedal slippage, etc. pretty bad! Good luck. It probably didn't help that I used to try to set speed records with the turbo fins.
Sounds like what a airforce pilot would do.. lol break speed records:whistling:
 

·
Registered
Joined
·
5,602 Posts
Discussion Starter #10
I used my wifes mirage system today and I noticed it was popping too after I put the turbo fins on it. I noticed it only does it when I push it really hard and fast. Even when I pushed it hard and fast with the regular fins it did not do it. I guess I need to be easier on them but at times I feel like I need to get the yak on plane lol.
 
1 - 10 of 10 Posts
Top