Pensacola Fishing Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,056 Posts
Discussion Starter #1
Bow navigation light inop. Replaced with new Atwood 10" nav light. Small task light that sits just under and to the rear of the red/green lens works fine. Replaced light bulb. Checked wiring at dash and at plug-in. 2-wire system.

WTF is wrong???
 

·
Registered
Joined
·
404 Posts
Put a voltmeter to the bow light socket, check for voltage. If voltage is good, about 12V, try another bulb.
If no voltage in bow light socket, check the wires coming FROM task light,assuming it is using same wires as bow light. If there are splices or wire nuts, probably corrosion. Redo wiring but seal it to prevent air or moisture getting to connections, liquid rubber or heat shrink tape.
Good luck.
 

·
Jaded Old Phart
Joined
·
5,923 Posts
What Boatfly says for voltage check. If you do have voltage, look at bottom of bulb and socket and hit with pencil eraser to clean contact areas.
If you had grease in contact areas, throw away pencil...
If you don't have voltage, start from connectors to new light and work your back to switch.
 

·
Registered
Joined
·
2,056 Posts
Discussion Starter #5
First of all - thx to floater1 for the offer and to Jaded Old Phart and Boatfly for the advice. This is how f'ed up things can get. After checking everything at least a thousand times, I took the Atwood bow light back to Walmart, got my $$$ back, went back to the limited marine stuff and picked up a 2nd $25 Atwood bow nav light. Plugged it in and same thing - small task light working, main nav light not. Now, I've decided to just sink the damn boat. But was in Academy Sports yesterday and noticed a $15 Marine Raider bow Nav light. Thinking that if this didn't work, it would be a long drive to get my $15 back. Took it home, plugged it in and, BOOM - nav light worked!!! Back-to-back new Atwoods were INOP!!!
 

·
Registered
Joined
·
3,648 Posts
Jaded Old Phart. LOL. Glad you got it working D Eagle.
 
1 - 6 of 6 Posts
Top