Suzuki DF150 - Pensacola Fishing Forum

Go Back   Pensacola Fishing Forum > Boating Topics > Boat Repair - Questions,Answers and Suggestions

Like Tree3Likes
  • 1 Post By jspooney
  • 1 Post By MaxP
  • 1 Post By MaxP
Reply
 
Thread Tools Search this Thread Display Modes
Old 06-09-2019, 05:23 PM   #1
Senior Member
Grouper
 
Join Date: Jan 2008
Posts: 890
Default Suzuki DF150

I launched the boat today took it out 8 miles and after idling on my fishing spot for a few minutes the engine died. The only way to get it running again was to put it in neutral and advance the throttle then started up. I did all the normal fuel system checks replace the primer bulb and some fuel hose and I can get it to run at idle speed with the throttle in neutral and advanced but the second I pull it straight back into idle neutral position the motor dies and I get two beeps. Does anyone have an idea what the issue is?
MaxP is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-09-2019, 08:05 PM   #2
Member
Ruby Red Lip
 
Join Date: Jan 2009
Posts: 90
Default

What year motor, is it digital or convention and do have the multi
function gauge that flashes codes.
seacat is offline   Reply With Quote Quick reply to this message
Old 06-09-2019, 09:40 PM   #3
Senior Member
Grouper
 
Join Date: Jan 2008
Posts: 890
Default

It is a 2012. I have the basic gauge that has the warning light cluster at the bottom of the tach. I didn't get any lights. Just two tones when the engine killed.
MaxP is offline   Reply With Quote Quick reply to this message
 
Old 06-09-2019, 10:11 PM   #4
Green Eggs And Ham
Grand Slam
 
Boat-Dude's Avatar
 
Join Date: Sep 2011
Posts: 7,539
Default

I wonder if you are making oil, check the level of the oil.
__________________
https://www.pensacolafishingforum.com/signaturepics/sigpic17230_2.gif
Boat-Dude is offline   Reply With Quote Quick reply to this message
Old 06-09-2019, 10:18 PM   #5
Senior Member
Grand Slam
 
Join Date: Oct 2007
Location: Gulf Breeze
Posts: 12,059
Default

Its the idle air control valve. Only time I've been towed from the gulf was a few years ago when mine went out. 3 screws hold it in place. Easy fix. From Suzuki or any dealer the part is $300. Go to Autozone and get the same exact part for about $150 with a lifetime warranty. Or go with Ebay for $20. Personally, I wanted the OEM Mitsubishi part from Autozone. It's too important so I didn't go with the Ebay China route. Here's a post on THT about it. https://www.thehulltruth.com/boating...r-strokes.html
Boat-Dude likes this.
jspooney is offline   Reply With Quote Quick reply to this message
Old 06-10-2019, 09:01 AM   #6
Senior Member
Grouper
 
Join Date: Jan 2008
Posts: 890
Default

Thank you, I have one ordered. I'll replace it later this week.
MaxP is offline   Reply With Quote Quick reply to this message
Old 06-12-2019, 04:37 PM   #7
Senior Member
Grouper
 
Join Date: Jan 2008
Posts: 890
Default

But one of the off brand valves and it worked for about 20 minutes. No one carried the Mitsubishi valve in stock except for Paradise Marine so I had to bite the bullet get the OEM. So far so good I'll give it another workout on Friday.
Boat-Dude likes this.
MaxP is offline   Reply With Quote Quick reply to this message
Old 06-12-2019, 09:50 PM   #8
Member
Ruby Red Lip
 
Join Date: Jan 2009
Posts: 90
Default

Advance has them for around $130. Ebay iacv have worked well and have got good service out of them. Single motor boat I would go for OEM or Mitsuubichi.
seacat is offline   Reply With Quote Quick reply to this message
Old 06-15-2019, 08:14 AM   #9
Senior Member
Grouper
 
Join Date: Jan 2008
Posts: 890
Default

Idled great all day yesterday. Turns out the OEM part is Mitsubishi. Also, getting to that back screw was a pain. I needed an offset screwdriver with another inch of reach.
Boat-Dude likes this.

Last edited by MaxP; 06-15-2019 at 08:30 AM.
MaxP is offline   Reply With Quote Quick reply to this message
Old 06-16-2019, 08:29 AM   #10
Senior Member
Grand Slam
 
Join Date: Oct 2007
Location: Gulf Breeze
Posts: 12,059
Default

Yes, the one from the auto parts store is the exact same part as the one from the marine dealer, except for the extra doubled price.
jspooney is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pensacola Fishing Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
How Did You Find Us?
Tell us how you heard about Pensacola Fishing Forum.

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT -4. The time now is 03:31 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 RC 2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.