Primos 35 cam quit - Pensacola Fishing Forum

Go Back   Pensacola Fishing Forum > Hunting/Shooting Forum > Hunting Forum

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-22-2012, 06:50 PM   #1
Super Moderator
Sailfish
 
MikeG's Avatar
 
Join Date: Oct 2007
Posts: 2,433
Default Primos 35 cam quit

Anyone else have one of these just stop?
MikeG is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-22-2012, 06:53 PM   #2
Senior Member
White Marlin
 
Join Date: Jul 2010
Location: Destin
Posts: 3,113
Default

Mine has never been great, batteries eat up so it is retired on the shelf
FrankwT is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 07:39 PM   #3
Super Moderator
Sailfish
 
MikeG's Avatar
 
Join Date: Oct 2007
Posts: 2,433
Default

This thing lasted a whole season last year on one set of batteries and took about 7000 pics. I have a second one that did the same. Now one just quit after a year.
MikeG is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 08:15 PM   #4
Senior Member
White Marlin
 
Join Date: Jul 2010
Location: Destin
Posts: 3,113
Default

I opened a service ticket for mine
https://primos.zendesk.com/home
FrankwT is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 09:00 PM   #5
Super Moderator
Sailfish
 
MikeG's Avatar
 
Join Date: Oct 2007
Posts: 2,433
Default

I heard they want like 75 bucks to fix a 79 dollar cam. I guess I get what I pay for.
MikeG is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 09:28 PM   #6
Senior Member
White Marlin
 
Join Date: Jul 2010
Location: Destin
Posts: 3,113
Default

Well they will not get that from me, That is why I stay w the Moultrie M-80 since I first started buying them.
FrankwT is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 10:18 PM   #7
Member
Ruby Red Lip
 
Join Date: Oct 2007
Posts: 35
Default Problems with 46 too

I bought one of the first series Primos 46 before last hunting season and it has great battery life and takes good pictures. I havent had the first problem with it.

Based on that experience, I decided to buy two more that were refurbished. When they arrived I noticed that they looked a little different and I was able to determine that they were the second series 46's. I guess you truly get what you pay for because they have both been nothing but trouble. Currently they both give the "SD FULL" error whenever I try to use them. I have both of them out of the woods and am beginning the process of trying to figure out what I need to do to get them fixed or replaced. Based on everything I have been reading online lately, I dont have much faith that I will resolve the issues.

Lesson learned...my 7 year old Moultries are still going strong...stick with what works.
SRCFIRE is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 10:58 PM   #8
Super Moderator
Sailfish
 
MikeG's Avatar
 
Join Date: Oct 2007
Posts: 2,433
Default cam

Well I hooked up a 12v wall plug to it tonight and it worked fine. Must be bad batteries. These batteries were brand new Duracells about 5 days ago. They should run several months. I guess its eating them.
MikeG is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 10:59 PM   #9
Senior Member
White Marlin
 
Try'n Hard's Avatar
 
Join Date: Oct 2008
Location: Santa Rosa County
Posts: 3,769
Default

I think they will replace them but will not respond to any questions or get in any rush. If I had to do it all over again I would not use the zen desk / ticket method and get them on the phone and make them communicate with me. My replacement 46 got put on the side of a tree this morning. I about half expect it to work right. Good luck

Last edited by Try'n Hard; 09-22-2012 at 11:05 PM.
Try'n Hard is offline   Reply With Quote Quick reply to this message
Old 09-22-2012, 10:59 PM   #10
Senior Member
White Marlin
 
Join Date: Jul 2010
Location: Destin
Posts: 3,113
Default

I have had problems w the walmart bought batteries some dead in the box
FrankwT is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pensacola Fishing Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT -4. The time now is 06:24 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2